Make your own free website on Tripod.com

Browser Upgrade Needed!

This site makes use of Java 1.1 which is supported in Netscape Navigator 4.06 (and above) and Microsoft Internet Exporer 4.0 (and above). Click on a browser logo below to upgrade.

Netscape Netcenter             Download the Internet Explorer